<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>&#8220;Football is Life&#8221; Podcast: Ben &amp; Jerry are out, plus high school football championship week | SportzEdge</title>
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://sportzedge.com/xmlrpc.php">
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=sportzedge.com&amp;id=84694025&amp;t=1512720520&amp;back=http%3A%2F%2Fsportzedge.com%2F2017%2F12%2F07%2Ffootball-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//mgtvsportzedge.wordpress.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel="alternate" type="application/rss+xml" title="SportzEdge &raquo; Feed" href="http://sportzedge.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SportzEdge &raquo; Comments Feed" href="http://sportzedge.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="SportzEdge &raquo; &#8220;Football is Life&#8221; Podcast: Ben &amp; Jerry are out, plus high school football championship week Comments Feed" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
	
<meta name="google-site-verification" content="bzYHGxqovN6KhPRifc1tQjaOWqxtUtMhRdYQmhj3lNU">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@sportzedge">

<meta name='description' content='In this edition of the &quot;Football is Life Podcast,&quot; the Giants have finally pulled the plug on Ben and Jerry.' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyFT9FOwzAM/CGMVQnGeJj2LWlqOm9xatXOuv096aqBGKi8WOfTnX2Hk0IcslN2lAKaSs/ZcNI4CJhwouvD9hzNnvBvW+ITGR7JNcQT3LY1eRxGqrxo8Fkh1HGgRFJla7aJu5682u2OwemyahHd3B/N8FDjrSZbGretjmQGdQoXAT/UbP80kjn9Uv0W8AezWBnz4Fzd9gV+3Vxe4ZkVvzOBhp4gF2lpNOzoI5Tkj/x8ai+75uV9s31rtq/N8RPwY7Wp' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/wp-content/themes/vip/lin-media/static/css/global.css?m=1508447976h' type='text/css' media='all' />
<style id='lin-style-inline-css' type='text/css'>
body,body .site-header .site-header-container{background-position: top center; background-repeat: repeat-x;} @media screen and (max-width: 991px){body .site-header .site-header-container{background-image: url( https://mgtvsportzedge.files.wordpress.com/2015/02/sportzedge-2015-bkg_2560x768.png?w=1000&h=768&crop=1 );}} @media screen and (min-width: 992px){body{background-attachment: fixed; background-image: url( https://mgtvsportzedge.files.wordpress.com/2015/02/sportzedge-2015-bkg_2560x768.png );} body .site-header .site-header-container{background-image: url( https://mgtvsportzedge.files.wordpress.com/2015/02/sportzedge-2015-bkg_2560x768.png );}}
</style>
<link rel='stylesheet' id='font-awesome-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-4-1' href='https://s1.wp.com/_static/??-eJyNktFuwyAMRX9ozMpWaevDtG8xhBK3DkaYrOvfD7ZIXdQK9Yl75XuMsYBzMk5i8bFAmfzsFb4oAVM0sx8JgaKDFshklyJZzUiaGC/gVO8WnmvhCf61nReTeAkUFc40Bl8UiiSTRKvScmH/CHJA563IyTCdqvh+nFRxhGyoRramBwcvhsVhIYkbYw6MlHto9pYlVBl+d3S1PQhda24xX1Uv3pb3NwnohLndtZ49an18HUe25gZav8K0g8BikVvgc/4Ydvu3l/dheB2OPxw41p8=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var linScreens = {"screen_groups":{"any":{"label":"[any screen]","min_width_px":null,"max_width_px":-1,"experience":null,"layout":null},"smallest":{"label":"Smallest screens (\"phones only\")","min_width_px":null,"max_width_px":480,"experience":"smartphone","layout":"small-responsive"},"smaller":{"label":"Smaller screens (\"phones to portrait tablets\")","min_width_px":null,"max_width_px":767,"experience":"tablet-portrait","layout":"medium-responsive"},"not_smallest":{"label":"Above-smallest screens (\"portrait tablets and up\")","min_width_px":481,"max_width_px":-1,"experience":null,"layout":null},"medium":{"label":"Medium screens (\"tablets\")","min_width_px":481,"max_width_px":991,"experience":null,"layout":"medium-responsive"},"larger":{"label":"Larger screens (\"landscape tablets and up\")","min_width_px":768,"max_width_px":-1,"experience":"desktop","layout":null},"largest":{"label":"Largest screens (\"desktops\")","min_width_px":992,"max_width_px":-1,"experience":"desktop","layout":"desktop"}},"experiences":{"smartphone":["smallest"],"tablet-portrait":["smaller"],"desktop":["larger","largest"]},"layouts":{"small-responsive":["smallest"],"medium-responsive":["smaller","medium"],"desktop":["largest"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVjusKwjAMRl/Irgrq9If4LF0bt9ReZpNu6NPbgYLiUIRAIDnfSeTYCwzaZQMkbalLhnR9tMrSQn4DhMc2KYbKY3jCOgaGwBPrY4MORCZIqi2zIjrFGa6PxB6ICjSzfX8Jw4Aw/sQscK/0WSQgvH1YuYNyTw7YS4dBeDCoJLFi1JNqgGBiqpocjPs324Ey8JI9+sNqs9yt1/W+3to7qQyIlg=='></script>
<script type="text/javascript" src="https://lin-d.openx.net/w/1.0/jstag?nc=5678-MediaGeneral"></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mgtvsportzedge.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p5JmMF-NKk' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fsportzedge.com%2F2017%2F12%2F07%2Ffootball-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fsportzedge.com%2F2017%2F12%2F07%2Ffootball-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="&#8220;Football is Life&#8221; Podcast: Ben &amp; Jerry are out, plus high school football championship week" />
<meta property="og:url" content="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/" />
<meta property="og:description" content="In this edition of the &#8220;Football is Life Podcast,&#8221; the Giants have finally pulled the plug on Ben and Jerry." />
<meta property="article:published_time" content="2017-12-08T03:06:17+00:00" />
<meta property="article:modified_time" content="2017-12-08T03:06:17+00:00" />
<meta property="og:site_name" content="SportzEdge" />
<meta property="og:image" content="https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg" />
<meta property="og:image:width" content="650" />
<meta property="og:image:height" content="371" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="&#8220;Football is Life&#8221; Podcast: Ben &amp; Jerry are out, plus high school football championship week" />
<meta name="twitter:image:src" content="https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg?w=640" />
<meta property="article:publisher" content="https://www.facebook.com/SportzEdge" />
<meta name="twitter:title" content="&#8220;Football is Life&#8221; Podcast: Ben &amp; Jerry are out, plus high school football championship week" />
<meta name="twitter:description" content="In this edition of the &#8220;Football is Life Podcast,&#8221; the Giants have finally pulled the plug on Ben and Jerry." />
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/9d92466f26853b6535cd853c0af620bf?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/9d92466f26853b6535cd853c0af620bf?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/9d92466f26853b6535cd853c0af620bf?s=114" />
<link rel='openid.server' href='http://mgtvsportzedge.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='http://mgtvsportzedge.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="http://sportzedge.com/osd.xml" title="SportzEdge" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

	<script type='text/javascript'>var _sf_startpt=(new Date()).getTime();</script>
	<script async type="text/javascript" id="bob_tag_loader">
		var cats = "NFL";
		var bob_kw = "";
		var bob_desc = "In this edition of the \"Football is Life Podcast,\" the Giants have finally pulled the plug on Ben and Jerry.";

		var cat_data  = "&cats=" + cats + "&bob_kw=" + bob_kw + "&bob_desc=" + bob_desc;
		var bob_cb  = '1';
		bob_cb= ((new Date()).getTime() + "" + Math.floor(Math.random() * 1000000)).substr(0, 16);
		(function() {
		var bob_tag = document.createElement('script'); bob_tag.type = 'text/javascript';
		bob_tag.async = true;
		bob_tag.id = "bob_tag";
		bob_tag.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'bob.dmpxs.com/static/bob_001.js?cms=wp&bob_cb=' + bob_cb + cat_data;
		var bts = document.getElementsByTagName('script')[0];
		bts.parentNode.insertBefore(bob_tag, bts);
		})();
	</script>
	


<link rel="canonical" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/" />
<meta http-equiv="refresh" content="1800">
<meta name="application-name" content="SportzEdge" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Connecticut Sports Coverage, National Sports Teams and in-depth UConn Huskies Reports" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://sportzedge.com/feed/;icon-uri=http://1.gravatar.com/blavatar/9d92466f26853b6535cd853c0af620bf?s=16" /><!-- Include Google_services.js -->
		<script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') +
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		<script type='text/javascript'>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</script>
<link rel="amphtml" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>

<!-- Begin comScore Tag -->
<script>
	var _comscore = _comscore || [];
	_comscore.push({ c1: "2", c2: "6036439" });
	(function() {
		var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
		s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
		el.parentNode.insertBefore(s, el);
	})();
</script>
<!-- End comScore Tag -->
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({article:'auto'});
	!function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		'https://cdn.taboola.com/libtrc/mediageneral-network/loader.js');
</script>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s0.wp.com/?custom-css=1&#038;csblog=5JmMF&#038;cscache=6&#038;csrev=8" />
		
<!--[if lt IE 9]>
<script src="https://s0.wp.com/wp-content/themes/vip/lin-media/static/js/selectivizr.min.js"></script>
<![endif]-->
</head>

<body class="post-template-default single single-post postid-191228 single-format-standard repeater-image mp6 customizer-styles-applied site-header-contracted non-entertainment has-header-leaderboard site-color-dark highlander-enabled highlander-light">



<div id='lin-wallpaper' class='dfp-ad'></div>
<div id="content-wrapper">
	<nav id="smaller-screen-navigation" class="offcanvas-navigation " role="navigation">
	<ul>
		<li class="menu-item">
			<a href="http://sportzedge.com/" rel="home">Home</a>
		</li>
		<li id="menu-item-5" class="menu-item menu-item-type-taxonomy menu-item-object-category    menu-item-has-children menu-item-5"><a href="http://sportzedge.com/category/college/">College</a>
<ul class="sub-menu">
	<li id="menu-item-9" class="menu-item menu-item-type-taxonomy menu-item-object-category    menu-item-9"><a href="http://sportzedge.com/category/college/uconn-mens-basketball/">UConn Men&#8217;s Basketball</a></li>
	<li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="http://sportzedge.com/category/college/uconn-women/">UConn Women&#8217;s Basketball</a></li>
	<li id="menu-item-34826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34826"><a href="http://sportzedge.com/category/college/uconn-football/">UConn Football</a></li>
	<li id="menu-item-164708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164708"><a href="http://sportzedge.com/category/college/uconn-baseball/">UConn Baseball</a></li>
	<li id="menu-item-164709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164709"><a href="http://sportzedge.com/category/college/uconn-hockey/">UConn Hockey</a></li>
	<li id="menu-item-34828" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34828"><a href="http://sportzedge.com/category/yale/">Yale</a></li>
	<li id="menu-item-6" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6"><a href="http://sportzedge.com/category/college/quinnipiac/">Quinnipiac</a></li>
	<li id="menu-item-7" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7"><a href="http://sportzedge.com/category/college/scsu/">SCSU</a></li>
	<li id="menu-item-39423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39423"><a href="http://sportzedge.com/category/unh/">UNH</a></li>
	<li id="menu-item-125545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-125545"><a href="http://collegefootball.ap.org/sportzedge/">NCAA College Football</a></li>
</ul>
</li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14"><a href="http://sportzedge.com/category/high-school/">High School</a>
<ul class="sub-menu">
	<li id="menu-item-34832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34832"><a href="http://sportzedge.com/category/high-school/hs-football/">High School Football</a></li>
	<li id="menu-item-178124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-178124"><a href="http://sportzedge.com/category/game-of-the-week/">Game of the Week</a></li>
	<li id="menu-item-34833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34833"><a href="http://sportzedge.com/category/high-school/hs-basketball/">High School Basketball</a></li>
	<li id="menu-item-44937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44937"><a href="http://sportzedge.com/category/high-school/hs-baseball/">High School Baseball</a></li>
	<li id="menu-item-153609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153609"><a href="http://sportzedge.com/category/high-school/hs-hockey/">High School Hockey</a></li>
	<li id="menu-item-166060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166060"><a href="http://sportzedge.com/category/high-school/high-school-softball/">H.S. Softball</a></li>
	<li id="menu-item-166061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166061"><a href="http://sportzedge.com/category/lacrosse/">High School Lacrosse</a></li>
</ul>
</li>
<li id="menu-item-161573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-161573"><a href="http://sportzedge.com/category/watch-live/">Watch Live</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="http://sportzedge.com/category/more/">More</a>
<ul class="sub-menu">
	<li id="menu-item-173356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-173356"><a href="http://sportzedge.com/category/nfl/">NFL</a>
	<ul class="sub-menu">
		<li id="menu-item-173357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173357"><a href="http://sportzedge.com/category/nfl/new-england-patriots/">New England Patriots</a></li>
		<li id="menu-item-173358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173358"><a href="http://sportzedge.com/category/nfl/new-york-giants/">New York Giants</a></li>
	</ul>
</li>
	<li id="menu-item-164710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164710"><a href="http://sportzedge.com/category/mlb/yankees/">Yankees</a></li>
	<li id="menu-item-166291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166291"><a href="http://sportzedge.com/category/nba/nba-finals/">NBA Finals</a></li>
	<li id="menu-item-164984" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164984"><a href="http://sportzedge.com/category/nba/nba-draft-profiles/">NBA Draft Profiles</a></li>
	<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="http://sportzedge.com/category/youth/">Youth</a></li>
	<li id="menu-item-135614" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-135614"><a href="http://sportzedge.com/2016/11/14/latest-highlight-videos/">Latest Highlight Videos</a></li>
	<li id="menu-item-126290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-126290"><a href="http://sportzedge.com/category/fantasy/">Fantasy</a></li>
	<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26"><a href="http://sportzedge.com/category/more/fitness/">Fitness</a></li>
	<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="http://sportzedge.com/category/more/fan-favorites/">Fan Favorites</a></li>
	<li id="menu-item-34831" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34831"><a href="http://sportzedge.com/category/sports-psychology/">Sports Psychology</a></li>
	<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="http://sportzedge.com/category/more/events/">Events</a></li>
</ul>
</li>
<li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57"><a href="http://sportzedge.com/report-it/">Report It</a></li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51"><a href="http://sportzedge.com/join-our-team/">Contribute</a>
<ul class="sub-menu">
	<li id="menu-item-42321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42321"><a href="http://sportzedge.com/join-our-team/team-sportzedge/">Team SportzEdge</a></li>
	<li id="menu-item-56611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56611"><a href="http://sportzedge.com/category/contributors/">Latest Contributor Articles</a></li>
	<li id="menu-item-53777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53777"><a href="http://sportzedge.com/about-us/follow-our-social-accounts/">Follow Our Social Accounts</a></li>
</ul>
</li>
<li id="menu-item-158479" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158479"><a href="http://sportzedge.com/category/podcasts/">Podcasts</a></li>
	</ul>
</nav>
	<div class="header-image">
		<div class="wallpaper-image">
			<div id="page" class="hfeed site">

				
				<header id="masthead" class="site-header" role="banner">
					<div class="site-header-container">
													<div class="row row-leaderboard">
								<div id='lin-header-leaderboard' class='dfp-ad'></div>							</div><!-- .row -->
						
						<!-- Contained at 1000px wide -->
						<div class="row header-row ">
							
							<div class="site-branding">
									<h1 class="site-logo ">
		<a href="http://sportzedge.com/" rel="home">
			<img src="https://mgtvsportzedge.files.wordpress.com/2015/04/sportzedge_300x60_v3.png" alt="SportzEdge">
		</a>
	</h1>
							</div><!-- .site-branding -->

							<div class="site-utilities">
																	<section class="current-weather">
											
		<aside class="weather-capsule">
			<figure class="weather-capsule-image">
				<img src="https://s0.wp.com/wp-content/themes/vip/lin-media/inc/wx_shortcodes/static/images/conditions/97.png" alt="Clear">
			</figure>
			<div class="weather-capsule-content-wrapper">
				<h3 class="weather-capsule-current-temperature">38&deg; <span class="temperature-scale">F</span></h3>
				<div class="weather-capsule-secondary-content-wrapper">
					<p class="weather-capsule-current-sky-conditions">Clear</p>
					<ul class="weather-capsule-list">
						<li>Hi: 46&deg; F</li>
						<li>Lo: 28&deg; F</li>
					</ul>
				</div><!-- .weather-capsule-secondary-content-wrapper -->
			</div><!-- .weather-capsule-content-wrapper -->
		</aside>

											<nav class="current-weather-navigation" role="navigation">
											<div class="menu-homepage-header-container"><ul id="menu-homepage-header" class="menu inline-navigation"><li id="menu-item-95" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="http://sportzedge.com/join-our-team/">Join Our Team</a></li>
<li id="menu-item-94" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-94"><a href="http://sportzedge.com/contact-us/request-us/">Request Us</a></li>
</ul></div>										</nav>
									</section>

									
																								</div><!-- .site-utilities -->
						</div><!-- .row -->
						<nav id="site-navigation" class="main-navigation" role="navigation">
							<h1 class="menu-toggle">Menu</h1>
							<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
							<div class="offcanvas-navigation-toggle offcanvas-navigation-toggle-icon toggle-icon-open">&nbsp;</div>
							<a href="http://sportzedge.com/" rel="home" class="home-link">Home</a>
															<div class="menu-main-navigation-container"><ul id="menu-main-navigation" class="menu"><li id="menu-item-5" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5"><a href="http://sportzedge.com/category/college/">College</a>
<ul class="sub-menu">
	<li id="menu-item-9" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9"><a href="http://sportzedge.com/category/college/uconn-mens-basketball/">UConn Men&#8217;s Basketball</a></li>
	<li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="http://sportzedge.com/category/college/uconn-women/">UConn Women&#8217;s Basketball</a></li>
	<li id="menu-item-34826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34826"><a href="http://sportzedge.com/category/college/uconn-football/">UConn Football</a></li>
	<li id="menu-item-164708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164708"><a href="http://sportzedge.com/category/college/uconn-baseball/">UConn Baseball</a></li>
	<li id="menu-item-164709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164709"><a href="http://sportzedge.com/category/college/uconn-hockey/">UConn Hockey</a></li>
	<li id="menu-item-34828" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34828"><a href="http://sportzedge.com/category/yale/">Yale</a></li>
	<li id="menu-item-6" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6"><a href="http://sportzedge.com/category/college/quinnipiac/">Quinnipiac</a></li>
	<li id="menu-item-7" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7"><a href="http://sportzedge.com/category/college/scsu/">SCSU</a></li>
	<li id="menu-item-39423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39423"><a href="http://sportzedge.com/category/unh/">UNH</a></li>
	<li id="menu-item-125545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-125545"><a href="http://collegefootball.ap.org/sportzedge/">NCAA College Football</a></li>
</ul>
</li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14"><a href="http://sportzedge.com/category/high-school/">High School</a>
<ul class="sub-menu">
	<li id="menu-item-34832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34832"><a href="http://sportzedge.com/category/high-school/hs-football/">High School Football</a></li>
	<li id="menu-item-178124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-178124"><a href="http://sportzedge.com/category/game-of-the-week/">Game of the Week</a></li>
	<li id="menu-item-34833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34833"><a href="http://sportzedge.com/category/high-school/hs-basketball/">High School Basketball</a></li>
	<li id="menu-item-44937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44937"><a href="http://sportzedge.com/category/high-school/hs-baseball/">High School Baseball</a></li>
	<li id="menu-item-153609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153609"><a href="http://sportzedge.com/category/high-school/hs-hockey/">High School Hockey</a></li>
	<li id="menu-item-166060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166060"><a href="http://sportzedge.com/category/high-school/high-school-softball/">H.S. Softball</a></li>
	<li id="menu-item-166061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166061"><a href="http://sportzedge.com/category/lacrosse/">High School Lacrosse</a></li>
</ul>
</li>
<li id="menu-item-161573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-161573"><a href="http://sportzedge.com/category/watch-live/">Watch Live</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="http://sportzedge.com/category/more/">More</a>
<ul class="sub-menu">
	<li id="menu-item-173356" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-173356"><a href="http://sportzedge.com/category/nfl/">NFL</a>
	<ul class="sub-menu">
		<li id="menu-item-173357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173357"><a href="http://sportzedge.com/category/nfl/new-england-patriots/">New England Patriots</a></li>
		<li id="menu-item-173358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173358"><a href="http://sportzedge.com/category/nfl/new-york-giants/">New York Giants</a></li>
	</ul>
</li>
	<li id="menu-item-164710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164710"><a href="http://sportzedge.com/category/mlb/yankees/">Yankees</a></li>
	<li id="menu-item-166291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166291"><a href="http://sportzedge.com/category/nba/nba-finals/">NBA Finals</a></li>
	<li id="menu-item-164984" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164984"><a href="http://sportzedge.com/category/nba/nba-draft-profiles/">NBA Draft Profiles</a></li>
	<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="http://sportzedge.com/category/youth/">Youth</a></li>
	<li id="menu-item-135614" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-135614"><a href="http://sportzedge.com/2016/11/14/latest-highlight-videos/">Latest Highlight Videos</a></li>
	<li id="menu-item-126290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-126290"><a href="http://sportzedge.com/category/fantasy/">Fantasy</a></li>
	<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26"><a href="http://sportzedge.com/category/more/fitness/">Fitness</a></li>
	<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="http://sportzedge.com/category/more/fan-favorites/">Fan Favorites</a></li>
	<li id="menu-item-34831" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34831"><a href="http://sportzedge.com/category/sports-psychology/">Sports Psychology</a></li>
	<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="http://sportzedge.com/category/more/events/">Events</a></li>
</ul>
</li>
<li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57"><a href="http://sportzedge.com/report-it/">Report It</a></li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51"><a href="http://sportzedge.com/join-our-team/">Contribute</a>
<ul class="sub-menu">
	<li id="menu-item-42321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42321"><a href="http://sportzedge.com/join-our-team/team-sportzedge/">Team SportzEdge</a></li>
	<li id="menu-item-56611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56611"><a href="http://sportzedge.com/category/contributors/">Latest Contributor Articles</a></li>
	<li id="menu-item-53777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53777"><a href="http://sportzedge.com/about-us/follow-our-social-accounts/">Follow Our Social Accounts</a></li>
</ul>
</li>
<li id="menu-item-158479" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158479"><a href="http://sportzedge.com/category/podcasts/">Podcasts</a></li>
</ul></div><form role="search" method="get" class="search-form search-form-not-toggled" action="http://sportzedge.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"  value="" name="s">
	</label>
	<input type="submit" class="search-submit" value="Search">
</form>
								<a href="#" class="search-toggle">Search the site</a>
														<div class="mobile-weather">
									
		<aside class="weather-capsule">
			<figure class="weather-capsule-image">
				<img src="https://s0.wp.com/wp-content/themes/vip/lin-media/inc/wx_shortcodes/static/images/conditions/97.png" alt="Clear">
			</figure>
			<div class="weather-capsule-content-wrapper">
				<h3 class="weather-capsule-current-temperature">38&deg; <span class="temperature-scale">F</span></h3>
				<div class="weather-capsule-secondary-content-wrapper">
					<p class="weather-capsule-current-sky-conditions">Clear</p>
					<ul class="weather-capsule-list">
						<li>Hi: 46&deg; F</li>
						<li>Lo: 28&deg; F</li>
					</ul>
				</div><!-- .weather-capsule-secondary-content-wrapper -->
			</div><!-- .weather-capsule-content-wrapper -->
		</aside>

								</div>
						</nav><!-- #site-navigation -->
												
						
					</div><!-- .site-header-container -->
				</header><!-- #masthead -->

				<div id="content" class="site-content">

					<div id='lin-pencil' class='dfp-ad'></div>
					<main id="main" class="site-main" role="main">

	<div id="primary" class="content-area" itemscope itemtype="http://schema.org/Article">

		
			
<article id="post-191228" class="content-single post-191228 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl" itemscope itemtype="http://schema.org/Article">
			<header class="entry-header">
			<h1 class="entry-title" itemprop="headline">&#8220;Football is Life&#8221; Podcast: Ben &amp; Jerry are out, plus high school football championship week</h1>
			
			<div class="entry-meta">
				
<div class="entry-meta-primary-column">
	<img alt='' src='http://0.gravatar.com/avatar/3b0bc8927015dbe218697f66c328acd3?s=44&#038;d=404&#038;r=G' class='avatar avatar-44' height='44' width='44' />	
<span class="byline">By <a href="http://sportzedge.com/author/sportzedgecontributor/" title="Posts by SportzEdge Contributor" class="author url fn" rel="author">SportzEdge Contributor</a></span>

<span class="posted-on">
	Published: <time class="entry-date published" datetime="2017-12-07T22:06:17+00:00">December 7, 2017, 10:06 pm</time></span>
</div><!-- .entry-meta-primary-column -->
	<div class="robots-nocontent sd-social-icon entry-header-sharing">
		<div class="sd-content">
			<ul>
																			<li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-191228" class="share-twitter sd-button share-icon no-text" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li>
																			<li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-191228" class="share-google-plus-1 sd-button share-icon no-text" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li>
																			<li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-191228" class="share-facebook sd-button share-icon no-text" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li>
																			<li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-191228" class="share-pinterest sd-button share-icon no-text" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li>
							</ul>
		</div>
	</div>
			</div><!-- .entry-meta -->
		</header><!-- .entry-header -->
	
	<div id="entry-content" class="entry-content">
					
<div class="entry-media-wrapper">
	<figure class="entry-media ">
		<img width="650" height="433" src="https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg?w=650" class="attachment-large size-large wp-post-image" alt="" srcset="https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg 650w, https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg?w=150 150w, https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg?w=300 300w" sizes="(max-width: 650px) 100vw, 650px" data-attachment-id="191229" data-permalink="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/ben-mcadoo-2/" data-orig-file="https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg" data-orig-size="650,433" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;AP&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;New York Giants head coach Ben McAdoo speaks at a news conference after an NFL football game between the Oakland Raiders and the Giants in Oakland, Calif., Sunday, Dec. 3, 2017. (AP Photo\/Marcio Jose Sanchez)&quot;,&quot;created_timestamp&quot;:&quot;1512348420&quot;,&quot;copyright&quot;:&quot;Copyright 2017 The Associated Press. All rights reserved.&quot;,&quot;focal_length&quot;:&quot;125&quot;,&quot;iso&quot;:&quot;4000&quot;,&quot;shutter_speed&quot;:&quot;0.0025&quot;,&quot;title&quot;:&quot;Ben McAdoo&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Ben McAdoo" data-image-description="" data-medium-file="https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg?w=300" data-large-file="https://mgtvsportzedge.files.wordpress.com/2017/12/ben-mcadoo.jpg?w=650" />
					<figcaption>
				New York Giants head coach Ben McAdoo speaks at a news conference after an NFL football game between the Oakland Raiders and the Giants in Oakland, Calif., Sunday, Dec. 3, 2017. (AP Photo/Marcio Jose Sanchez)			</figcaption>
		
	</figure>
</div>
		
		<div class="entry-content-wrap" itemprop="articleBody">
			<p>(WTNH)&#8211;In this edition of the &#8220;Football is Life Podcast,&#8221; the Giants have finally pulled the plug on Ben and Jerry. The Pats win but Gronk is getting some heat for his illegal hit. Plus, the college football playoff is set and its championship Saturday coming up in High School football.</p>
<p>Check out the latest edition of the &#8220;Football is Life&#8221; Podcast, with Dan Zumpano and Chris Rzasa, formerly of Southern Connecticut State’s WSIN radio.</p>
<p>Listen in by hitting the play button on the clip below:</p>
<!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]-->
<audio class="wp-audio-shortcode" id="audio-191228-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://mgtvsportzedge.files.wordpress.com/2017/12/football-is-life-ep-13.mp3?_=1" /><a href="https://mgtvsportzedge.files.wordpress.com/2017/12/football-is-life-ep-13.mp3" target="_blank">https://mgtvsportzedge.files.wordpress.com/2017/12/football-is-life-ep-13.mp3</a></audio>
<div class="post_author_box"><p><a href="http://sportzedge.com/author/sportzedgecontributor/">More stories</a> by SportzEdge Contributor</p></div><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-191228" class="share-twitter sd-button share-icon" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-191228" class="share-facebook sd-button share-icon" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-191228" class="share-google-plus-1 sd-button share-icon" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;width:150px;"><ul style="background-image:none;"><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-191228" class="share-pinterest sd-button share-icon no-text" href="http://sportzedge.com/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-84694025-191228-5a2a4888e123c' data-src='//widgets.wp.com/likes/#blog_id=84694025&amp;post_id=191228&amp;origin=mgtvsportzedge.wordpress.com&amp;obj_id=84694025-191228-5a2a4888e123c' data-name='like-post-frame-84694025-191228-5a2a4888e123c'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>
								<div class="related-posts-wrap">
		<h4>Related Posts</h4>
		<div class="related-posts">
											
<article id="post-189748" class="figurehead-object  post-189748 post type-post status-publish format-standard has-post-thumbnail hentry category-new-york-giants category-nfl category-podcasts">
		<div class="figurehead-object-body">
						<figure class="entry-thumbnail">
		<a href="http://sportzedge.com/2017/11/29/football-is-life-podcast-eli-gets-benched-whos-in-college-football-playoff/"  rel="bookmark"><img width="151" height="85" src="https://mgtvsportzedge.files.wordpress.com/2017/11/eli-manning.jpg?w=151&amp;h=85&amp;crop=1" class="attachment-lin-thumbnail size-lin-thumbnail wp-post-image" alt="" srcset="https://mgtvsportzedge.files.wordpress.com/2017/11/eli-manning.jpg?w=151&amp;h=85&amp;crop=1 151w, https://mgtvsportzedge.files.wordpress.com/2017/11/eli-manning.jpg?w=302&amp;h=170&amp;crop=1 302w" sizes="(max-width: 151px) 100vw, 151px" data-attachment-id="189749" data-permalink="http://sportzedge.com/2017/11/29/football-is-life-podcast-eli-gets-benched-whos-in-college-football-playoff/eli-manning-2/" data-orig-file="https://mgtvsportzedge.files.wordpress.com/2017/11/eli-manning.jpg" data-orig-size="650,433" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;AP&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;ARCHIVO - En esta foto del 23 de noviembre de 2017, el quarterback Eli Manning (10) de los Giants de Nueva York se retira de la cancha tras la derrota 20-10 ante los Redskins de Washington. (AP Foto\/Patrick Semansky)&quot;,&quot;created_timestamp&quot;:&quot;1511498014&quot;,&quot;copyright&quot;:&quot;Copyright 2017 The Associated Press. All rights reserved.&quot;,&quot;focal_length&quot;:&quot;38&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;Eli Manning&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Eli Manning" data-image-description="" data-medium-file="https://mgtvsportzedge.files.wordpress.com/2017/11/eli-manning.jpg?w=300" data-large-file="https://mgtvsportzedge.files.wordpress.com/2017/11/eli-manning.jpg?w=650" /></a>
	</figure><!-- .entry-thumbnail -->
		
		<header class="entry-header">
			<h1 class="entry-title"><a href="http://sportzedge.com/2017/11/29/football-is-life-podcast-eli-gets-benched-whos-in-college-football-playoff/"  rel="bookmark">&#8220;Football is Life&#8221; Podcast: Eli gets benched; who&#8217;s in College Football Playoff?</a></h1>

					</header><!-- .entry-header -->

			</div><!-- .figurehead-object-body -->

	<footer class="entry-meta">
			</footer><!-- .entry-meta -->

	</article><!-- #post-## -->
											
<article id="post-187013" class="figurehead-object  post-187013 post type-post status-publish format-standard has-post-thumbnail hentry category-new-york-giants category-nfl category-podcasts">
		<div class="figurehead-object-body">
						<figure class="entry-thumbnail">
		<a href="http://sportzedge.com/2017/11/15/football-is-life-podcast-the-giants-are-officially-the-worst-team-in-football/"  rel="bookmark"><img width="151" height="85" src="https://mgtvsportzedge.files.wordpress.com/2017/11/mcadoo.jpg?w=151&amp;h=85&amp;crop=1" class="attachment-lin-thumbnail size-lin-thumbnail wp-post-image" alt="" srcset="https://mgtvsportzedge.files.wordpress.com/2017/11/mcadoo.jpg?w=151&amp;h=85&amp;crop=1 151w, https://mgtvsportzedge.files.wordpress.com/2017/11/mcadoo.jpg?w=302&amp;h=170&amp;crop=1 302w" sizes="(max-width: 151px) 100vw, 151px" data-attachment-id="187018" data-permalink="http://sportzedge.com/2017/11/15/football-is-life-podcast-the-giants-are-officially-the-worst-team-in-football/ben-mcadoo/" data-orig-file="https://mgtvsportzedge.files.wordpress.com/2017/11/mcadoo.jpg" data-orig-size="650,474" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;AP&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;New York Giants head coach Ben McAdoo speaks at a news conference after an NFL football game between the San Francisco 49ers and the Giants in Santa Clara, Calif., Sunday, Nov. 12, 2017. (AP Photo\/Marcio Jose Sanchez)&quot;,&quot;created_timestamp&quot;:&quot;1510533714&quot;,&quot;copyright&quot;:&quot;Copyright 2017 The Associated Press. All rights reserved.&quot;,&quot;focal_length&quot;:&quot;180&quot;,&quot;iso&quot;:&quot;2500&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;Ben McAdoo&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Ben McAdoo" data-image-description="" data-medium-file="https://mgtvsportzedge.files.wordpress.com/2017/11/mcadoo.jpg?w=300" data-large-file="https://mgtvsportzedge.files.wordpress.com/2017/11/mcadoo.jpg?w=650" /></a>
	</figure><!-- .entry-thumbnail -->
		
		<header class="entry-header">
			<h1 class="entry-title"><a href="http://sportzedge.com/2017/11/15/football-is-life-podcast-the-giants-are-officially-the-worst-team-in-football/"  rel="bookmark">&#8220;Football is Life&#8221; Podcast: The Giants are officially the worst team in football</a></h1>

					</header><!-- .entry-header -->

			</div><!-- .figurehead-object-body -->

	<footer class="entry-meta">
			</footer><!-- .entry-meta -->

	</article><!-- #post-## -->
											
<article id="post-188440" class="figurehead-object  post-188440 post type-post status-publish format-standard has-post-thumbnail hentry category-new-england-patriots category-nfl category-podcasts tag-chris-rzasa tag-dan-zumpano tag-football-is-life tag-football-is-life-podcast tag-football-podcast tag-nfl-podcast">
		<div class="figurehead-object-body">
						<figure class="entry-thumbnail">
		<a href="http://sportzedge.com/2017/11/22/football-is-life-podcast-thanksgiving-week-edition/"  rel="bookmark"><img width="151" height="85" src="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-11.jpg?w=151&amp;h=85&amp;crop=1" class="attachment-lin-thumbnail size-lin-thumbnail wp-post-image" alt="" srcset="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-11.jpg?w=151&amp;h=85&amp;crop=1 151w, https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-11.jpg?w=302&amp;h=170&amp;crop=1 302w" sizes="(max-width: 151px) 100vw, 151px" data-attachment-id="188441" data-permalink="http://sportzedge.com/2017/11/22/football-is-life-podcast-thanksgiving-week-edition/tom-brady-18/" data-orig-file="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-11.jpg" data-orig-size="650,442" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;AP&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;Tom Brady, quarterback de los Patriots de Nueva Inglaterra, lanza un pase frente a los Raiders de Oakland, durante el partido realizado el domingo 19 de noviembre de 2017 en la Ciudad de M\u00e9xico (AP Foto\/Rebecca Blackwell)&quot;,&quot;created_timestamp&quot;:&quot;1511128762&quot;,&quot;copyright&quot;:&quot;Copyright 2017 The Associated Press. All rights reserved.&quot;,&quot;focal_length&quot;:&quot;560&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0004&quot;,&quot;title&quot;:&quot;Tom Brady&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Tom Brady" data-image-description="" data-medium-file="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-11.jpg?w=300" data-large-file="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-11.jpg?w=650" /></a>
	</figure><!-- .entry-thumbnail -->
		
		<header class="entry-header">
			<h1 class="entry-title"><a href="http://sportzedge.com/2017/11/22/football-is-life-podcast-thanksgiving-week-edition/"  rel="bookmark">&#8220;Football is Life&#8221; Podcast: Thanksgiving Week Edition</a></h1>

					</header><!-- .entry-header -->

			</div><!-- .figurehead-object-body -->

	<footer class="entry-meta">
			</footer><!-- .entry-meta -->

	</article><!-- #post-## -->
											
<article id="post-185762" class="figurehead-object  post-185762 post type-post status-publish format-standard has-post-thumbnail hentry category-new-england-patriots category-new-york-giants category-nfl category-podcasts">
		<div class="figurehead-object-body">
						<figure class="entry-thumbnail">
		<a href="http://sportzedge.com/2017/11/08/football-is-life-podcast-how-bad-are-the-giants-really-plus-jets-pats-picks-and-more/"  rel="bookmark"><img width="151" height="85" src="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-denver.jpg?w=151&amp;h=85&amp;crop=1" class="attachment-lin-thumbnail size-lin-thumbnail wp-post-image" alt="" srcset="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-denver.jpg?w=151&amp;h=85&amp;crop=1 151w, https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-denver.jpg?w=302&amp;h=170&amp;crop=1 302w" sizes="(max-width: 151px) 100vw, 151px" data-attachment-id="185765" data-permalink="http://sportzedge.com/2017/11/08/football-is-life-podcast-how-bad-are-the-giants-really-plus-jets-pats-picks-and-more/patriots-broncos/" data-orig-file="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-denver.jpg" data-orig-size="650,442" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;AP&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;Tom Brady, quarterback de los Patriots de Nueva Inglaterra, lanza un pase frente a los Broncos de Denver en el partido celebrado el domingo 18 de diciembre de 2016 (AP Foto\/Jack Dempsey)&quot;,&quot;created_timestamp&quot;:&quot;1482106818&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;400&quot;,&quot;iso&quot;:&quot;2500&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;PATRIOTS-BRONCOS&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="PATRIOTS-BRONCOS" data-image-description="" data-medium-file="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-denver.jpg?w=300" data-large-file="https://mgtvsportzedge.files.wordpress.com/2017/11/tom-brady-denver.jpg?w=650" /></a>
	</figure><!-- .entry-thumbnail -->
		
		<header class="entry-header">
			<h1 class="entry-title"><a href="http://sportzedge.com/2017/11/08/football-is-life-podcast-how-bad-are-the-giants-really-plus-jets-pats-picks-and-more/"  rel="bookmark">&#8220;Football is Life&#8221; Podcast: How bad are the Giants, really? Plus Jets, Pats, picks and more</a></h1>

					</header><!-- .entry-header -->

			</div><!-- .figurehead-object-body -->

	<footer class="entry-meta">
			</footer><!-- .entry-meta -->

	</article><!-- #post-## -->
								</div>
	</div>
			
			
<div class="mobile river-ad-wrapper river-first-ad-wrapper">
	<div id='lin-river-first' class='dfp-ad'><p class="advertisement-label">Advertisement</p></div></div>
					</div>
	</div><!-- .entry-content -->

	<footer class="entry-meta">
					</footer><!-- .entry-meta -->
</article><!-- #post-## -->

			<nav class="navigation post-navigation" role="navigation">
	<div class="nav-links">
					<a class="previous-post-link" href="http://sportzedge.com/2017/12/04/giants-to-do-an-about-face-on-elis-starting-gig/">
				&laquo; Previous Story			</a>
							</div>
</nav>

			
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'thumbnails-a',
		container: 'taboola-below-article-thumbnails',
		placement: 'Below Article Thumbnails',
		target_type: 'mix'
	});
</script>

					<p class="comment-disclaimer">SportzEdge.com provides commenting to allow for constructive discussion on the stories we cover. In order to comment here, you acknowledge you have read and agreed to our Terms of Service. Commenters who violate these terms, including use of vulgar language or racial slurs, will be banned. Please be respectful of the opinions of others. If you see an inappropriate comment, please flag it for our moderators to review.</p>
	
	<div itemprop="comment">
		
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus</a>.</noscript>

<div id="comments" class="comments-area" data-show-immediately="0">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://sportzedge.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="d1201d3997" /><input type="hidden" name="_wp_http_referer" value="/2017/12/07/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="http://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="http://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="http://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="http://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="http://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='191228' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c388fc2573" /></p>
<input type="hidden" name="genseq" value="1512720520" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="196"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->
	</div>
	
		
		
<div id="grv-personalization-42" class="gravity-wrapper"></div>

	</div><!-- #primary -->


	<div id="secondary" class="widget-area" role="complementary">
		<!-- BEGIN Companion Wrapper --><div id="lr_comp_default_300x250"><div class="dfp-ad lin-rr-top"><div id="lin-rr-top"><p class="advertisement-label">Advertisement</p></div></div></div><!--/#comp_default--><div id="lr_comp_300x250" style="display:block;"></div><!-- END Companion Wrapper --><div class="widget-visibility-wrapper show-on-any"><aside id="facebook-likebox-2" class="widget widget_facebook_likebox"><h1 class="widget-title"><a href="https://www.facebook.com/SportzEdge">Like SportzEdge on Facebook</a></h1>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/SportzEdge" data-width="340"  data-height="432" data-hide-cover="true" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/SportzEdge"><a href="https://www.facebook.com/SportzEdge">Like SportzEdge on Facebook</a></blockquote></div>
		</div>
		</aside></div><!-- .widget-visibility-wrapper --><div class="widget-visibility-wrapper show-on-any"><aside id="top-posts-3" class="widget widget_top-posts"><h1 class="widget-title">Top Posts &amp; Pages</h1><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="http://sportzedge.com/2014/07/01/7-reasons-why-soccer-kind-of-sucks/" title="7 Reasons Why Soccer is the Dumbest Sport Ever" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="http://mgtvsportzedge.files.wordpress.com/2014/07/soccer-flop.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="7 Reasons Why Soccer is the Dumbest Sport Ever" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://sportzedge.com/2014/07/01/7-reasons-why-soccer-kind-of-sucks/" class="bump-view" data-bump-view="tp">
								7 Reasons Why Soccer is the Dumbest Sport Ever							</a>
						</div>
											</li>
									<li>
												<a href="http://sportzedge.com/2017/12/06/aaron-boone-knows-he-has-to-convince-players-he-can-manage/" title="Aaron Boone knows he has to convince players he can manage" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="http://mgtvsportzedge.files.wordpress.com/2017/12/aaron-boone-1.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Aaron Boone knows he has to convince players he can manage" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://sportzedge.com/2017/12/06/aaron-boone-knows-he-has-to-convince-players-he-can-manage/" class="bump-view" data-bump-view="tp">
								Aaron Boone knows he has to convince players he can manage							</a>
						</div>
											</li>
									<li>
												<a href="http://sportzedge.com/2014/07/23/who-are-the-five-greatest-dunkers-in-basketball-history/" title="Who is the greatest dunker in NBA history?" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="http://mgtvsportzedge.files.wordpress.com/2014/07/greatest-dunkers.png?w=1200&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="Who is the greatest dunker in NBA history?" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://sportzedge.com/2014/07/23/who-are-the-five-greatest-dunkers-in-basketball-history/" class="bump-view" data-bump-view="tp">
								Who is the greatest dunker in NBA history?							</a>
						</div>
											</li>
									<li>
												<a href="http://sportzedge.com/2017/12/05/greenwich-darien-face-each-other-for-title-of-best-team-in-state/" title="Greenwich, Darien face each other for title of &#039;best team in state&#039;" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="http://mgtvsportzedge.files.wordpress.com/2017/12/2017-12-5-greenwich-football.jpg?w=1200&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="Greenwich, Darien face each other for title of &#039;best team in state&#039;" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://sportzedge.com/2017/12/05/greenwich-darien-face-each-other-for-title-of-best-team-in-state/" class="bump-view" data-bump-view="tp">
								Greenwich, Darien face each other for title of &#039;best team in state&#039;							</a>
						</div>
											</li>
									<li>
												<a href="http://sportzedge.com/2017/12/07/two-run-heavy-offenses-should-make-for-quick-game-as-killingly-joel-barlow-battle-for-title/" title="Two run-heavy offenses should make for quick game as Killingly, Joel Barlow battle for title" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="http://mgtvsportzedge.files.wordpress.com/2017/12/2017-12-7-killingly-football.jpg?w=1200&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="Two run-heavy offenses should make for quick game as Killingly, Joel Barlow battle for title" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://sportzedge.com/2017/12/07/two-run-heavy-offenses-should-make-for-quick-game-as-killingly-joel-barlow-battle-for-title/" class="bump-view" data-bump-view="tp">
								Two run-heavy offenses should make for quick game as Killingly, Joel Barlow battle for title							</a>
						</div>
											</li>
									<li>
												<a href="http://sportzedge.com/2014/07/12/ncaa-coolest-logo-tournament-index/" title="NCAA Coolest Logo Tournament Index" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="http://mgtvsportzedge.files.wordpress.com/2014/07/logos-ncaa.png?w=1200&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="NCAA Coolest Logo Tournament Index" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://sportzedge.com/2014/07/12/ncaa-coolest-logo-tournament-index/" class="bump-view" data-bump-view="tp">
								NCAA Coolest Logo Tournament Index							</a>
						</div>
											</li>
				</ul>
</aside></div><!-- .widget-visibility-wrapper --><div class="widget-visibility-wrapper show-on-any"><aside id="twitter_timeline-4" class="widget widget_twitter_timeline"><h1 class="widget-title">Follow @SportzEdge on Twitter</h1><a class="twitter-timeline" data-width="300" data-height="400" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-widget-id="345244167825420288">My Tweets</a></aside></div><!-- .widget-visibility-wrapper --><div id='lin-rr-bottom' class='dfp-ad'><p class="advertisement-label">Advertisement</p></div>	</div><!-- #secondary -->
	<div id="secondary-placeholder"></div>

							<div class="tablet desktop">
								<div id='lin-footer-leaderboard' class='dfp-ad'><p class="advertisement-label">Advertisement</p></div>							</div><!-- .tablet.desktop -->

															<div class="row solitary-column">
									
<div class="mobile river-ad-wrapper river-last-ad-wrapper">
	<div id='lin-river-last' class='dfp-ad'><p class="advertisement-label">Advertisement</p></div></div>
								</div>
							
					</main><!-- #main -->

				</div><!-- #content -->

				<footer id="colophon" class="site-footer" role="contentinfo">
					<div class="info-nav-wrapper">
						<section class="site-info">
							<h2><a class="unmarked-link" href="http://sportzedge.com/" rel="home">SportzEdge</a></h2>
															<a href="http://www.nexstar.tv/" class="footer-logo" title="Nexstar Media Group, Inc">
																						<img width="180" height="94" src="https://mgtvsportzedge.files.wordpress.com/2017/01/nexstar-logo-black2.png?w=180" class="attachment-medium size-medium" alt="Nexstar Media Group, Inc." srcset="https://mgtvsportzedge.files.wordpress.com/2017/01/nexstar-logo-black2.png 180w, https://mgtvsportzedge.files.wordpress.com/2017/01/nexstar-logo-black2.png?w=150 150w" sizes="(max-width: 180px) 100vw, 180px" data-attachment-id="146157" data-permalink="http://sportzedge.com/nexstar-logo-black2/" data-orig-file="https://mgtvsportzedge.files.wordpress.com/2017/01/nexstar-logo-black2.png" data-orig-size="180,94" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="nexstar-logo-black2" data-image-description="" data-medium-file="https://mgtvsportzedge.files.wordpress.com/2017/01/nexstar-logo-black2.png?w=180" data-large-file="https://mgtvsportzedge.files.wordpress.com/2017/01/nexstar-logo-black2.png?w=180" />																						</a>
														<p>© 1998-2017 wtnh.com | <a href="http://www.nexstar.tv/" title="Nexstar Broadcasting, Inc">Nexstar Broadcasting, Inc.</a> | All rights reserved.</p>
															<p>Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=sportzedge.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></p>
													</section><!-- .site-info -->
						<nav role="navigation">
							<div class="column-navigation column-navigation-4"><h3 class="column-navigation-heading">Sitemap</h3><div class="menu-sitemap-container"><ul id="menu-sitemap" class="menu"><li id="menu-item-58" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58"><a href="http://sportzedge.com/category/youth/">Youth</a></li>
<li id="menu-item-59" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59"><a href="http://sportzedge.com/category/high-school/">High School</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category    menu-item-60"><a href="http://sportzedge.com/category/college/">College</a></li>
<li id="menu-item-61" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61"><a href="http://sportzedge.com/category/more/">More</a></li>
<li id="menu-item-62" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62"><a href="http://sportzedge.com/report-it/">Report It</a></li>
<li id="menu-item-63" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63"><a href="http://sportzedge.com/join-our-team/">Contribute</a></li>
</ul></div></div><div class="column-navigation column-navigation-4"><h3 class="column-navigation-heading">Company</h3><div class="menu-company-container"><ul id="menu-company" class="menu"><li id="menu-item-42" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42"><a href="http://www.mediageneral.com/">Media General</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43"><a href="http://wtnh.com/">WTNH.com</a></li>
<li id="menu-item-53776" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53776"><a href="http://sportzedge.com/about-us/follow-our-social-accounts/">Follow Our Social Accounts</a></li>
</ul></div></div><div class="column-navigation column-navigation-4"><h3 class="column-navigation-heading">Legal</h3><div class="menu-legal-container"><ul id="menu-legal" class="menu"><li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://wtnh.com/about-us/terms-of-service/">Terms Of Service</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://wtnh.com/about-us/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50"><a href="http://sportzedge.com/join-our-team/contributor-faq/">Contributor FAQ</a></li>
</ul></div></div><div class="column-navigation column-navigation-4"><h3 class="column-navigation-heading">Request Us</h3><div class="menu-request-us-container"><ul id="menu-request-us" class="menu"><li id="menu-item-53212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53212"><a href="http://sportzedge.com/contact-us/request-us/">Request SportzEdge</a></li>
</ul></div></div>						</nav>
					</div>
					<section class="follow-wrapper">
						<h3 class="follow-heading">Follow</h3>
						<nav role="navigation" class="social-icons">
	<ul class="social-icons-list ">
		<li>
			<a class="social-icon-item feed" href="http://sportzedge.com/feed/">
				<span>Subscribe via RSS</span>
							</a>
		</li>
					<li>
				<a class="social-icon-item twitter" href="https://twitter.com/SportzEdge">
					<span>Follow us on Twitter</span>
									</a>
			</li>
							<li>
				<a class="social-icon-item facebook" href="https://www.facebook.com/SportzEdge">
					<span>Join us on Facebook</span>
									</a>
			</li>
							<li>
				<a class="social-icon-item youtube" href="https://www.youtube.com/user/SportzEdge">
					<span>Follow us on YouTube</span>
									</a>
			</li>
							<li>
				<a class="social-icon-item googleplus" href="https://plus.google.com/+Sportzedge/" rel="publisher">
					<span>Follow us on Google+</span>
									</a>
			</li>
							<li>
				<a class="social-icon-item pinterest" href="https://pinterest.com/https://www.pinterest.com/sportzedge/">
					<span>Follow us on Pinterest</span>
									</a>
			</li>
							</ul>
</nav>
<div class="widget-visibility-wrapper show-on-any"><aside id="text-2" class="widget widget_text">			<div class="textwidget"><script type="text/javascript">var host = (("https:" == document.location.protocol) ? "https://secure." : "http://");document.write(unescape("%3Cscript src='" + host + "wufoo.com/scripts/embed/form.js'  type='text/javascript'%3E%3C/script%3E"));</script><script type='text/javascript'>var wufoo_q1l25ed50hsl3ez = new WufooForm();wufoo_q1l25ed50hsl3ez .initialize({'userName':'linforms', 'formHash':'q1l25ed50hsl3ez', 'autoResize':1,'height':'577','header':'show' ,'ssl':1});wufoo_q1l25ed50hsl3ez.display();</script> <noscript> <iframe allowTransparency="true" frameborder="0" scrolling="no" style="width:100%;border:none;"src="https://linforms.wufoo.com/embed/q1l25ed50hsl3ez/"><a href="https://linforms.wufoo.com/forms/q1l25ed50hsl3ez/" rel="nofollow" target="_blank">Fill out my Wufoo form!</a></iframe> </noscript></div>
		</aside></div><!-- .widget-visibility-wrapper -->					</section>
				</footer><!-- #colophon -->
			</div><!-- #page -->

			<div class="mobile nx-mweb-adhesion">
											</div>

			<!-- wpcom_wp_footer -->
	<script type='text/javascript'>
		var _sf_async_config = _sf_async_config || {};
		/** CONFIGURATION START **/
		_sf_async_config.uid = 23192;
		_sf_async_config.domain = "";
		_sf_async_config.useCanonical = true;
		_sf_async_config.sections = "";
		_sf_async_config.authors = "";
		/** CONFIGURATION END **/
	</script>
<script>
	(function() {
		function loadChartbeat() {
			window._sf_endpt = (new Date()).getTime();
			var e = document.createElement('script');
			e.setAttribute('language', 'javascript');
			e.setAttribute('type', 'text/javascript');
			e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
			document.body.appendChild(e);
		}
		var oldonload = window.onload;
		window.onload = (typeof window.onload != 'function') ?
			loadChartbeat : function() {
				oldonload();
				loadChartbeat();
			};
	})();
</script>

<!-- Begin comScore Tag -->
<noscript>
	<img src="http://b.scorecardresearch.com/p?c1=2&#038;c2=6036439&#038;cv=2.0&#038;cj=1" alt="" />
</noscript>
<!-- End comScore Tag -->
		
<div id="gallery-above-ad" style="display: none;">
	</div>
<div id="gallery-sidebar-ad" style="display: none;">
	</div>
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201749y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-3b0bc8927015dbe218697f66c328acd3">
	</div>
	<div class="grofile-hash-map-3b0bc8927015dbe218697f66c328acd3">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/mgtvsportzedge.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/mgtvsportzedge.wordpress.com\/wp-login.php?action=logout&_wpnonce=395ce897b4","homeURL":"http:\/\/sportzedge.com\/","postID":"191228","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/sportzedge.com\/2017\/12\/07\/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week\/":191228};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
		<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/_static/??-eJzTLy/QzcxLzilNSS3WzyrWz01NyUxMzUnNTc0rQeEU5CRWphbp5qSmJyZX6uVm5uklFxfr6OPTDpRD5sM02efaGpoaWJobmplYmmYBAHQdL1Q=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var lin = {"colors":{"backgroundColor":""},"singular":{"permalink":"http:\/\/sportzedge.com\/2017\/12\/07\/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week\/","postType":"post","showContinueReading":true},"stationId":"sportzedge","l10n":{"continueReading":"Continue Reading","loadMoreStories":"Load More Stories","hideComments":"Hide Comments","showComments":"Show Comments"},"disqus":{"domain":"disqus.com","facebookXdReceiverPath":"http:\/\/mgtvsportzedge.wordpress.com\/wp-content\/themes\/vip\/plugins\/disqus\/xd_receiver.htm","identifierForPost":"191228 http:\/\/sportzedge.com\/?p=191228","shortname":"sportzedge","version":"2.40"},"ads":{"wpArticlePostTypes":["post","page","investigative-story","autopub_ap_story"],"category":["NFL"],"post_tag":[],"description":"In this edition of the \"Football is Life Podcast,\" the Giants have finally pulled the plug on Ben and Jerry."},"entertainmentTheme":{"isUsing":false},"hero":{"layout":false},"asyncSidebars":{"endpoint":"http:\/\/sportzedge.com\/wp-json\/lin\/v1\/sidebars\/asynchronicity","queryString":{"year":"2017","monthnum":"12","day":"07","name":"football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week"}}};
var gallery_strings = {"no_gallery_modal_set":"No gallery modal set.","modal_does_not_have_class":"Modal set but does not have proper class: \"lin-gallery-modal\".","show_more":"More","show_less":"Less","pager":"%1$d of %2$d","captions":{"on":"Turn Captions On","off":"Turn Captions Off"},"thumbnails":{"on":"Show Thumbnails","off":"Hide Thumbnails"},"galleries":{"on":"Latest Galleries","off":"Hide Galleries"}};
var webpackFlags = {"feature":"","needsModernizr":"1"};
var linGA = {"hasDefaultProperty":"1","hasAdditionalProperties":"","is404":"","defaultProperty":"UA-32507368-63","additionalProperties":[]};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVkF1uAjEMhC/UxFCBoA9Vj1JlExMc8kfi7JbbNwtCghZR9dX2jL8ZmLLQKTJGBlfB4Ega85d09QVuVqGJ7JulWMHTASscGzbcq2g8lifHOoXQR+IicrN6gDpRxv+I7gZXIUXtm7kctGiwVJ0KykDxpzXvMfS7kXJ/H0VAQwoqKyZ9zrzL0maWPlnbw6QRSyHzC/APF+vToLwc2lzJI8ZriILZnx5h3jTgkLPSB/jsBsATMWMRTAH752fNvYoZz50phYrKnzrd3NhHeF+uF9vN23qxWrpvsl66Ow=='></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"channelUrl":"https:\/\/mgtvsportzedge.wordpress.com\/wp-content\/themes\/vip\/plugins\/facebook\/channel.php","xfbml":true,"appId":"270079849786883"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}
		if (Array.prototype.forEach) {
			var fbPosts = document.querySelectorAll('fb\\:post');
			Array.prototype.forEach.call(fbPosts, function(el) {
				el.setAttribute('data-width', el.parentNode.offsetWidth);
			});
		}
	}
/* ]]> */
</script>
<div id="fb-root"></div><script type="text/javascript">(function(d){var id="facebook-jssdk";if(!d.getElementById(id)){var js=d.createElement("script"),ref=d.getElementsByTagName("script")[0];js.id=id,js.async=true,js.src="http:\/\/connect.facebook.net\/en_US\/all.js",ref.parentNode.insertBefore(js,ref)}})(document)</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"84694025","siteName":"SportzEdge","siteURL":"http:\/\/sportzedge.com","icon":"<img alt='' src='http:\/\/1.gravatar.com\/blavatar\/9d92466f26853b6535cd853c0af620bf?s=50&d=https%3A%2F%2Fs1.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"vip\/lin-media","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/mgtvsportzedge.wordpress.com\/wp-login.php?redirect_to=http%3A%2F%2Fsportzedge.com%2F2017%2F12%2F07%2Ffootball-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week%2F","themeURL":"","xhrURL":"http:\/\/sportzedge.com\/wp-admin\/admin-ajax.php","nonce":"0ede1b7eb4","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"08af4d9bb3\" \/>","referer":"http:\/\/sportzedge.com\/2017\/12\/07\/football-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week\/","canFollow":"1","feedID":"34836929","statusMessage":"","customizeLink":"https:\/\/mgtvsportzedge.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fmgtvsportzedge.wordpress.com%2F2017%2F12%2F07%2Ffootball-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week%2F","postID":"191228","shortlink":"https:\/\/wp.me\/p5JmMF-NKk","canEditPost":"","editLink":"https:\/\/mgtvsportzedge.wordpress.com\/wp-admin\/post.php?post=191228&action=edit","statsLink":"https:\/\/wordpress.com\/stats\/post\/191228\/sportzedge.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: LIN Media","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 4,429 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/mgtvsportzedge.wordpress.com\/wp-login.php?redirect_to=http%3A%2F%2Fsportzedge.com%2F2017%2F12%2F07%2Ffootball-is-life-podcast-ben-jerry-are-out-plus-high-school-football-championship-week%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVj8sOgkAMRX/IYSCKhoXxU0wdChbmQdpB4987mKAsjMFVbx/n3lTfB2WCj+ijdqMa7NiSFw21I68uwNqBROSkVLghM9Uon1nWyUavd4gMppdfkIkU/AS91XxN3thxCu9SPtYEaNG98EWjwNfJDB7IWYr/j3XUMkRcBabdsl8y397qSRxGtc1yfU6eugnsftwPQaJqLBBruQKTb+eaoJM7FmVeHYr9riq7J49PpvA='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({flush: true});
</script>
		<iframe src='http://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'84694025','blog_tz':'-5','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'84694025','v':'wpcom','tz':'-5','user_id':'0','post':'191228','subd':'mgtvsportzedge'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=84694025&v=wpcomvt&tz=-5&user_id=0&post=191228&subd=mgtvsportzedge&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTdDNXdwSDNzY2t3TXpdMHlwa2VYWEwxYSU/eDhaOTJJQUhvamMwWit2eGtRdFF4fE5SczVFcGI5eUNxaD02emowTkhReWM4ZUFYM2ZnR0dkZE5pR1V+cWpaXUZSYUtpRG9TQUVzLGtJSS8vQXx2Mlhwdk52V0g3JXJmb0ZIW2g4cS1ZcVJMPzJ3NkosRXIvZFFlLyZtUmtoMjM/QzJvaExkLlo0bmJPekdJRTJGN0FpbXpKOGU9Zkd4MDRubjcuMlI2TD9hST1zQkZSZnB8VWcwTW1pUXp4Wy9Wa1E2RytBWz9iUVBjLSxnLmZdLjJpM250OD1TZlAyOHhYNW9NN0ZVeHdiV2ZLcw=='}]);
_stq.push([ 'clickTrackerInit', '84694025', '191228' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
			<!-- Google Analytics -->
<script>
	if ( typeof linGA !== 'undefined' && linGA.hasDefaultProperty ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

		linGA.allProperties = [ linGA.defaultProperty ].concat( linGA.additionalProperties );
		linGA.startTracking = function() {
			jQuery.each( ga.getAll(), function( i, tracker ) {
				name = tracker.get( 'name' );
				ga( name + '.require', 'displayfeatures' );
				ga( name + '.send', 'pageview' );
				if ( linGA.is404 ) {
					ga( name + '.send', 'event', '404', document.location.href, document.referrer );
				}
			});
		};
		linGA.trackExternal = function( e ) {
			try {
				jQuery.each( ga.getAll(), function( i, tracker ) {
					ga( tracker.get( 'name' ) + '.send', 'event', 'Outbound Links', e.currentTarget.host, jQuery( this ).attr( 'href' ) );
				});
				// h/t https://wordpress.org/plugins/wp-google-analytics
				if ( ! ( e.metaKey || e.ctrlKey || 1 == e.button || '_blank' == jQuery( this ).attr( 'target' ) ) ) {
					e.preventDefault();
					setTimeout( 'document.location = "' + jQuery( this ).attr( 'href' ) + '"', 150 );
				}
			} catch( err ) {}
		};

		/**
		 * Send a GA event to all properies.
		 *
		 * @param  {string} category - Event category
		 * @param  {string} action - Event action
		 * @param  {string} label - Event label
		 */
		linGA.trackEvent = function( category, action, label ) {
			try {
				// Send event to all tracking properties.
				jQuery.each( ga.getAll(), function( i, tracker ) {
					ga( tracker.get( 'name' ) + '.send', 'event', category, action, label );
				} );
			} catch ( err ) {}
		}

		jQuery.each( linGA.allProperties, function( i, property ) {
			ga( 'create', property, 'auto', { 'name': 't' + i } );
		});
		ga( linGA.startTracking );
		jQuery( 'a:external' ).on( 'click', linGA.trackExternal );

		// Track "Continue Reading" events.
		window.addEventListener( 'lin:continueReading', function() {
			linGA.trackEvent( 'Button', 'Tap', 'Continue Reading' );
		}, false );

		// Track "Load More Stories" events.
		window.addEventListener( 'lin:loadMoreStories', function() {
			linGA.trackEvent( 'Button', 'Tap', 'Load More Stories' );
		}, false );
	}
</script>
<!-- End Google Analytics -->

		</div><!-- .wallpaper-image -->
	</div><!-- .header-image -->
</div> <!-- #content-wrapper -->

</body>
</html>
<!--
	generated in 0.181 seconds
	111678 bytes batcached for 300 seconds
-->
